Cabinet issue - Brockworth
Incident Report for Gigaclear
Resolved
This issue has been resolved, many thanks for your patience.
Posted Feb 01, 2023 - 09:54 GMT
Investigating
We are investigating an issue affecting customers attached to the cabinet in Brockworth.

Updates will be posted here as soon as the fault has been identified. We do not currently have an estimated time of recovery.
Posted Jan 31, 2023 - 22:27 GMT
This incident affected: Internet Network (Gloucestershire).