Cabinet issue - Puckrup
Incident Report for Gigaclear
Resolved
This incident has been resolved. If you have any problems with your service after the outage, please contact our Customer Support team on 01865 591131 or email support@gigaclear.com.

We appreciate your patience on this matter and apologise for any inconvenience it may cause.

Kind Regards
The Gigaclear Team
Posted Sep 16, 2019 - 14:46 BST
Investigating
We are investigating an issue affecting customers attached to the cabinet in Puckrup (GL20 6JH).

Updates will be posted here as soon as the fault has been identified. We do not currently have an estimated time of recovery.
Posted Sep 16, 2019 - 10:22 BST