Bagshot, Surrey
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Feb 07, 2023 - 17:27 GMT
Investigating
We are aware that some customers are experiencing a loss in service in the Bagshot area. We are currently working on a fix plan to restore service as quickly as possible. we will confirm once resource has been assigned to resolve this issue.We thank you for your patience in this matter.
Posted Jan 24, 2023 - 12:27 GMT
This incident affected: Internet Network (Surrey).