Unplanned outage in Welford
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Oct 12, 2020 - 23:38 BST
Monitoring
We have restored affected services in Welford, and continue to monitor the situation to ensure no further fault.
Posted Oct 12, 2020 - 22:24 BST
Investigating
We’ve just been informed by our Network Operations team that there’s an issue with the service in the Welford area.

Our engineers are investigating the cause of this problem and are doing everything they can to restore your broadband service as quickly as possible
Posted Oct 12, 2020 - 21:22 BST
This incident affected: Internet Network (Northamptonshire).