Yeovil South - Somerset - SW-YEVS
Incident Report for Gigaclear
Resolved
This incident is resolved.
Posted Nov 13, 2024 - 09:39 GMT
Update
We are continuing to investigate this issue.
Posted Nov 13, 2024 - 08:06 GMT
Investigating
Gigaclear Networks have informed us that there is an issue with the service in your area. Our engineers are investigating what has caused the problem and are doing everything they can to restore your service as quickly as possible.
Posted Nov 13, 2024 - 08:06 GMT
This incident affected: Internet Network (Devon & Somerset).