Over Kiddington, Oxfordshire

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Aug 27, 2026 - 15:45 BST

Investigating

We are aware of an internet service interruption affecting customers in the Over Kiddington area. This is due to an ongoing power cut in the area, which is affecting our cabinet in area. We are monitoring the situation and will provide further updates once the power supply has been restored. We apologise for any inconvenience caused.
Posted Aug 27, 2026 - 01:41 BST
This incident affected: Internet Network (Oxfordshire).