Your service is now back online as this outage has been resolved. If you're still experiencing issues, please reach out to our team on 01865 591131
Posted Sep 21, 2026 - 14:48 BST
Update
Our team are working as quickly as we can to restore service whilst we look for a replacement component. We have also got our engineers engaged to attempt a temporary fix to restore whilst we await a replacement component. Next update is 2:30PM regarding our engineer's progress. Thank you for your continued patience
Posted Sep 21, 2026 - 13:45 BST
Identified
We have identified the cause of this fault and our teams are working diligently to restore services as quickly as possible. Thank you for your ongoing patience
Posted Sep 21, 2026 - 11:49 BST
Investigating
We’ve just been informed by our Network Operations team that there’s an issue with the service in your local area. Our engineers are investigating the cause of this problem and are doing everything they can to restore your broadband service as quickly as possible.
Posted Sep 21, 2026 - 10:30 BST
This incident affected: Internet Network (Berkshire).