Cabinet issue Cavendish (East)

Incident Report for Gigaclear

Resolved

This cabinet is now back online. We will continue to monitor connections. Thank you for your patience and understanding.
Posted Nov 06, 2025 - 14:28 GMT

Investigating

We are investigating an issue affecting customers attached to the cabinet in LOCATION.

Updates will be posted here as soon as the fault has been identified. We do not currently have an estimated time of recovery.
Posted Nov 06, 2025 - 11:34 GMT
This incident affected: Internet Network (Essex).