Unplanned Outage Oxfordshire

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 13:55 BST

Investigating

We are currently investigating this issue.
Posted Jul 01, 2025 - 12:12 BST
This incident affected: Internet Network (Oxfordshire).