Warboys, Huntingdon

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 11:52 GMT

Update

We are continuing to work on a fix for this issue.
Posted Mar 17, 2025 - 08:52 GMT

Update

We are continuing to work on a fix for this issue.
Posted Mar 17, 2025 - 08:51 GMT

Identified

We have identified a fault affecting service in your area, and we are actively working to resolve the issue. We appreciate your patience during this time and assure you that we are committed to restoring service as quickly as possible. Thank you for your understanding
Posted Mar 17, 2025 - 08:50 GMT