Multiple Areas - Cambridgeshire & Northamptonshire

Incident Report for Gigaclear

Resolved

This incident is now resolved, thank you for your patience and apologies again for the inconvenience.
Posted May 01, 2026 - 11:48 BST

Identified

We're sorry for the ongoing service disruption. Our teams are working hard to restore service. We appreciate your patience.
Posted May 01, 2026 - 10:35 BST

Update

Thank you for your ongoing patience, our teams are working with third party providers to get this issue resolved as soon as possible. We'll keep you updated as work progresses. Sorry for the disruption.
Posted May 01, 2026 - 08:22 BST

Investigating

We are currently investigating service interruption affecting users in the Nottinghamshire and Cambridgeshire areas. Our engineers are working to resolve the issue as quickly as possible. We will provide further updates as more information becomes available. We apologise for the inconvenience and appreciate your patience.
Posted May 01, 2026 - 03:47 BST
This incident affected: Internet Network (Cambridgeshire, Northamptonshire).