A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2025 - 13:53 GMT
Update
Our engineers are still working hard to resolve the issue affecting your broadband service. While progress is being made, the repair is taking longer than expected.
We apologise for the disruption and appreciate your patience. We’ll continue to keep you updated as we work to restore your service as soon as possible.
Posted Mar 21, 2025 - 11:09 GMT
Update
We are continuing to work on a fix for this issue.
Posted Mar 21, 2025 - 08:14 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 21, 2025 - 03:07 GMT
Update
Unfortunately, it’s taking a little longer than we thought to resolve the issue that’s affected your broadband service today. Our engineers are still hard at work trying to resolve the issue and are hoping to restore the service in your area as soon as they can.
Posted Mar 21, 2025 - 03:06 GMT
Investigating
We’ve just been informed by our Network Operations team that there’s an issue with the service in your local area. Our engineers are investigating the cause of this problem and are doing everything they can to restore your broadband service as quickly as possible.
Posted Mar 21, 2025 - 01:44 GMT
This incident affected: Internet Network (Devon & Somerset).