Bruton and Gardens, Castle Cary

Incident Report for Gigaclear

Resolved

Good news, our engineers have now fixed the issue and your service has now been fully restored. You should be able to access your broadband service as usual.
Posted Apr 26, 2025 - 05:32 BST

Investigating

We’re aware there’s an issue with our service in your area. We’ve Engineers looking at the problem and are doing everything we can to get the issue resolved. We’ll update you again when we’ve more information and to let you know when the service will be restored. Apologies for any inconvenience caused.
Posted Apr 26, 2025 - 02:19 BST
This incident affected: Internet Network (Devon & Somerset).