ESSEX
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Jul 26, 2022 - 09:31 BST
Investigating
Due to the extreme heat, we are taking proactive measures to try cool the network and prevent any service disruption. We are closely monitoring the situation across the whole network.
Posted Jul 19, 2022 - 12:48 BST
This incident affected: Internet Network (Essex).