Cabinet issue - Gloucestershire (Chedworth)

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 14:05 GMT

Investigating

We are investigating an issue affecting customers attached to the cabinet in Gloucestershire (Chedworth) .

Updates will be posted here as soon as the fault has been identified. We do not currently have an estimated time of recovery.
Posted Dec 09, 2025 - 12:39 GMT
This incident affected: Internet Network (Gloucestershire).