Debden Green and Thaxted (East)
Incident Report for
Gigaclear
Resolved
Mains power restored , incident is now resolved
Posted
Jun
07
,
2025
-
08:55
BST
Monitoring
Mains power restored but we will keep monitoring
Posted
Jun
07
,
2025
-
08:07
BST
Update
Cabinets went down due to unplanned putage by UKPN, we are sending teams
Posted
Jun
07
,
2025
-
06:27
BST
Investigating
We are currently investigating this issue.
Posted
Jun
07
,
2025
-
06:26
BST
This incident affected: Internet Network (Essex).
×
Subscribe to Incident
Subscribe to updates for
Debden Green and Thaxted (East)
via . You'll receive .