Network issue - Wing, Leighton Buzzard
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Nov 27, 2021 - 23:26 GMT
Investigating
We have detected an issue affecting multiple cabinets and customers connected to them in Wing . Our engineers are investigating the cause.

We will update this page with further information as soon as we have identified the fault. We do not currently have an estimated time of recovery.
Posted Nov 27, 2021 - 21:42 GMT
This incident affected: Internet Network (Bedfordshire).