This incident has been resolved. Monitoring systems overnight have confirmed all customers are back online.
Posted Feb 13, 2026 - 09:01 GMT
Investigating
We are aware of a service disruption impacting the Curridge area of Berkshire. Our teams are working to restore service as quickly as possible. We appreciate your patience and apologise for any inconvenience caused.
Posted Feb 12, 2026 - 15:40 GMT
This incident affected: Internet Network (Berkshire).