Service Degradation - Wiltshire
Incident Report for
Gigaclear
Resolved
This incident is now resolved.
Posted
Nov
15
,
2025
-
12:54
GMT
Investigating
We have been made aware that some customers are experiencing degradation to their services in Wiltshire.
Our engineers are working to restore this issue, and will update this page when we have further information.
Posted
Nov
14
,
2025
-
21:36
GMT
This incident affected: Internet Network (Wiltshire).
×
Subscribe to Incident
Subscribe to updates for
Service Degradation - Wiltshire
via . You'll receive .