Network resiliency works have been complete. This incident is now resolved.
If you are still experiencing any problems, please raise a ticket via our customer portal so that our team can assist you.
Posted Mar 12, 2026 - 18:20 GMT
Monitoring
The team has confirmed that all services have now been fully restored. Further work is currently being undertaken to enhance the resilience of the network.
We appreciate your patience throughout the duration of the issue. If you are still experiencing any problems, please raise a ticket via our customer portal so that our team can assist you.
Posted Mar 12, 2026 - 17:57 GMT
Update
Restoration works are progressing smoothly, with a minor delay caused by strong winds. Splicing activities are currently underway, and we remain on track to restore services this evening. Further updates will be provided via the status page and text messages as additional information becomes available from the site.
Posted Mar 12, 2026 - 17:02 GMT
Update
Restoration work is ongoing to recover the affected services. Traffic management measures have been implemented, and fibre repair activities are currently in progress. The estimated time for restoration remains scheduled for this evening due to the work involved. Thank you for your continued patience.
Posted Mar 12, 2026 - 12:16 GMT
Update
A temporary fix is currently not possible. We are working alongside other affected fibre companies to restore services. A new pole will be installed overnight and our engineers will work to repair the affected fibre cables. An estimated time for repair is tomorrow evening. Further updates will be provided as work progresses. Thank you for your patience and understanding.
Posted Mar 11, 2026 - 19:11 GMT
Update
The team has identified that a BT pole housing our fibre-optic cable has been struck by a vehicle. Our direct labour team is currently assessing the most effective method to restore broadband services as quickly as possible.
Further updates will be provided once the expected repair timeframe has been confirmed. Thank you for your patience and understanding while we work to resolve the issue.
Posted Mar 11, 2026 - 18:54 GMT
Identified
Engineers are on-site and are currently working to fix the issue. Thank you for your continued patience and understanding.
Posted Mar 11, 2026 - 18:08 GMT
Investigating
We’re aware there’s an issue with our service in your area. Engineers are investigating the issue and are doing everything we can to get the issue resolved. We’ll update you again when we’ve more information and to let you know when the service will be restored. Apologies for any inconvenience caused.