We apologise for any inconvenience caused by the planned works commencing an hour earlier than scheduled. We currently expect the works to be completed anytime between now and 7:00 AM tomorrow morning. Thank you for your patience while we work to restore normal service.
Posted Mar 21, 2026 - 21:02 GMT
Investigating
The planned maintenance originally scheduled for 9:00 PM this evening has commenced earlier than expected. Our Network Operations Team is actively engaging with our third‑party contractors to understand the reason for the early start and to ensure the work is completed as quickly as possible. We will provide further updates as soon as more information becomes available.
Posted Mar 21, 2026 - 20:00 GMT
This incident affected: Internet Network (Devon & Somerset).