Ramsey, Needingworth, Oakham & Warboys - Cambridgeshire

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 09:35 BST

Update

We are continuing to investigate this issue.
Posted Apr 02, 2025 - 09:34 BST

Investigating

Our teams have identified an offline segment of our network and are working diligently to locate the fault as quickly as we can. Please accept our apologies for any inconvenience caused.
Posted Apr 02, 2025 - 08:33 BST
This incident affected: Internet Network (Cambridgeshire & Huntingdonshire).