Fibre Strike in Ashmore Green and Long Lane
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Sep 18, 2020 - 17:20 BST
Update
Gigaclear engineers continue to work to restore services in the affected areas, and will continue their restoration efforts though drawbacks slow our progress. We will update this page as soon as we have a more precise ETA, but expect all services restored by Friday afternoon.
Posted Sep 16, 2020 - 16:29 BST
Monitoring
Our crews are on site and have requested additional heavy dig equipment to expedite the repair. An ETA will follow for the restoration of all services.

Thank you for your patience.
Posted Sep 16, 2020 - 12:51 BST
Identified
Gigaclear engineers are currently working to restore services which have been brought down due to a broken fibre cable within the network. We will update this page again when we have an estimated time of repair.
Posted Sep 15, 2020 - 14:30 BST
This incident affected: Internet Network (Berkshire).