Cabinet issue - Beachley (South West) SW-BEACHE

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 14:29 BST

Update

We are continuing to investigate this issue.
Posted Sep 05, 2025 - 13:52 BST

Investigating

We are investigating an issue affecting customers attached to the cabinet in Beachley (South West) SW-BEACHE.

Updates will be posted here as soon as the fault has been identified. We do not currently have an estimated time of recovery.
Posted Sep 05, 2025 - 10:49 BST
This incident affected: Internet Network (Gloucestershire).