Great Chesterford & Little Chesterford - Essex

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 18:33 BST

Identified

We are currently investigating intermittent connectivity issues in the Great Chesterford and Little Chesterford areas of Essex. Our engineering team has identified the cause and is working on a resolution. We apologise for the disruption and appreciate your patience.
Posted Apr 07, 2026 - 16:12 BST
This incident affected: Internet Network (Essex).