Devon and Somerset

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 12:11 BST

Identified

Our engineers are on-site working to restore power to the cabinet. We will continue to provide updates when they become available. Thank you for your patience.
Posted Apr 23, 2026 - 11:33 BST

Investigating

We are currently investigating service interruption affecting users in the Millhayes, Dalwood, Uplyme , Beacon and Awliscombe (South West). Our engineers are working to resolve the issue as quickly as possible. We will provide further updates as more information becomes available. We apologise for the inconvenience and appreciate your patience.
Posted Apr 23, 2026 - 10:55 BST
This incident affected: Internet Network (Devon, Somerset).