Glendon, Northamptonshire
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 11:05 BST
Investigating
Our teams have identified an offline cabinet currently affected by a local power outage in the Glendon area. We have dispatched our Direct Labour Team with a generator to temporarily power the cabinet to restore services until National Grid confirms power restoration in the area.

Please accept our apologies for any inconvenience caused.
Posted Apr 15, 2024 - 10:20 BST
This incident affected: Internet Network (Northamptonshire).