Upload Speed Issues in Oxfordshire
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Jul 01, 2020 - 00:18 BST
Identified
We have identified an issue on one of our Oxfordshire links that is causing issues with upload speed, we have engineers on their way to site to resolve and will update here as the situation progresses.
Posted Jun 30, 2020 - 11:24 BST
This incident affected: Internet Network (Oxfordshire).