Unplanned Outage Dumbleton (South West)

Incident Report for Gigaclear

Update

We are continuing to work on a fix for this issue.
Posted Dec 27, 2025 - 11:12 GMT

Update

Our engineers are currently on-site and actively working to resolve the issue, we will be continuing and we will keep you posted with further updates. Apologies for any inconvenience caused and thank you for your patience.
Posted Dec 27, 2025 - 11:12 GMT

Update

Our team are commencing splicing of the fibre cables as we speak and expect this to be done within the hour. Please make sure all your equipment is still switched on.
Posted Dec 24, 2025 - 16:10 GMT

Identified

Engineers are still working to repair remaining lines and bring you back online, we will be continuing and we will keep you posted with further updates. Apologies for any inconvenience caused and thank you for your patience.
Posted Dec 24, 2025 - 15:19 GMT
This incident affects: Internet Network (Gloucestershire).