All of our equipment has been confirmed as operational and the issue has been highlighted as an issue with the network backhaul. We await further updates from our partners. Thank you for your patience.
Posted Jul 28, 2026 - 12:46 BST
Update
We have engineers dispatched to site to further investigate with an estimated arrival by 12:45.
Posted Jul 28, 2026 - 12:16 BST
Investigating
We are currently investigating service interruption affecting users in the Bruton 02 area. Our engineers are working to resolve the issue as quickly as possible. We will provide further updates as more information becomes available. We apologise for the inconvenience and appreciate your patience.
Posted Jul 28, 2026 - 11:22 BST
This incident affects: Internet Network (Somerset).