Cabinet issue - Piddington ( Oxfordshire )

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Dec 07, 2025 - 21:42 GMT

Investigating

We are investigating an issue affecting customers attached to the cabinet in Piddington ( Oxfordshire ).

Updates will be posted here as soon as the fault has been identified. We do not currently have an estimated time of recovery.
Posted Dec 07, 2025 - 19:02 GMT
This incident affected: Internet Network (Oxfordshire).