A fix has now been implemented and we will be monitoring the issue until we are confident it is fixed. Thank you for your patience.
Posted Oct 27, 2025 - 10:46 GMT
Investigating
We are currently investigating an issue affecting our home phone and broadband service. Please avoid rebooting any of your equipment whilst we investigate.
Posted Oct 27, 2025 - 10:13 GMT
This incident affected: Network Services (DHCP, Home Phone Service).