Network Issue at Sandhurst Village - GL2 9NP
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Jul 23, 2020 - 16:06 BST
Investigating
We are investigating an issue affecting customers attached to the cabinet in Sandhurst Village - GL2 9NP

Updates will be posted here as soon as the fault has been identified. We do not currently have an estimated time of recovery.
Posted Jul 23, 2020 - 15:51 BST