Unplanned outage Crickham
Incident Report for Gigaclear
Resolved
This incident has been resolved and all services are back online. If you are still having issues please reboot your router, and if the issues persist, please call our customer operations team on 01865591131.
Posted Jun 14, 2022 - 19:35 BST
Investigating
We’ve just been informed by our Network Operations team that there’s an issue with the service in your local area.

Our engineers are investigating the cause of this problem and are doing everything they can to restore your broadband service as quickly as possible
Posted Jun 14, 2022 - 16:13 BST
This incident affected: Internet Network (Devon & Somerset).