Network Issue

Incident Report for Gigaclear

Resolved

We’ve now resolved the issue. If you’re still experiencing any connectivity problems, please reboot both your router and wall-mounted unit (modem), keeping them powered off for at least 15 minutes before switching them back on.

If the problem persists, please contact our Customer Service team. We apologise for any inconvenience caused and appreciate your patience.
Posted Nov 01, 2025 - 18:32 GMT

Update

We are continuing to investigate this issue.
Posted Nov 01, 2025 - 16:35 GMT

Investigating

We’re aware of an issue currently affecting service across the Gigaclear network. Our engineers are working diligently to restore connectivity as soon as possible. Please do not reboot or reset your router or wall-mounted unit during this time. We apologise for any inconvenience caused and appreciate your patience.
Posted Nov 01, 2025 - 16:15 GMT
This incident affected: Internet Network (Bedfordshire, Berkshire, Buckinghamshire, Cambridgeshire & Huntingdonshire, Derbyshire, Devon & Somerset, Essex, Gloucestershire, Herefordshire, Kent, Leicestershire, Lincolnshire, Northamptonshire, Oxfordshire, Rutland, Wiltshire, Worcestershire, Surrey, Hertfordshire, Warwickshire).