Service Degradation - Chepstow, Lydney

Incident Report for Gigaclear

Update

We are continuing to work on a fix for this issue.
Posted Jul 27, 2026 - 20:56 BST

Identified

We are currently investigating reports of service degradation affecting customers in Chepstow, Lydney, and surrounding areas. Our engineering teams have identified the issue and are actively working to restore services as quickly as possible.

We apologise for any inconvenience caused and will provide further updates as soon as more information becomes available.
Posted Jul 27, 2026 - 19:00 BST
This incident affects: Internet Network (Gloucestershire).