Cabinet issue - Rowney Green
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Sep 19, 2021 - 05:02 BST
Monitoring
A fix has been implemented by our backhaul supplier and we are monitoring the line,
Posted Sep 19, 2021 - 04:39 BST
Identified
We have identified the issue with the backhaul supplier to be a power issue their side. We will updated you with any further updates and we apologise for the inconvenience caused.
Posted Sep 19, 2021 - 04:08 BST
Update
We are continuing to investigate the issue.
Posted Sep 19, 2021 - 03:28 BST
Investigating
We are investigating an issue affecting customers attached to the cabinet in Rowney Green.

Updates will be posted here as soon as the fault has been identified. We do not currently have an estimated time of recovery.
Posted Sep 19, 2021 - 02:28 BST
This incident affected: Internet Network (Worcestershire).