Core Network

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 11:40 BST

Update

We are continuing to work on a fix for this issue.
Posted Apr 20, 2026 - 09:34 BST

Update

We are continuing to investigate this issue and our engineers are working to restore service. We apologise for the inconvenience and appreciate your patience.
Posted Apr 20, 2026 - 09:33 BST

Update

We are continuing to work on a fix for this issue.
Posted Apr 20, 2026 - 08:44 BST

Identified

Our Senior Networks team have identified an issue and have advised that customers should reboot their routers, guidance on how to do this can be found on our support page. We apologise for any inconveniences caused.
Posted Apr 20, 2026 - 08:33 BST

Investigating

We are currently investigating service interruption, our engineers are working to resolve the issue as quickly as possible. We will provide further updates as more information becomes available. We apologise for the inconvenience and appreciate your patience.
Posted Apr 20, 2026 - 08:33 BST