Suffolk - Sudbury (ngmf-01)
Incident Report for
Gigaclear
Resolved
We have confirmed that the service issue affecting Suffolk has been fixed. We apologise for any inconvenience caused and thank you for your patience.
Posted
Apr
17
,
2025
-
18:58
BST
Update
Our engineers are currently on site and will be working throughout this evening for your connection restoration. Thank you for your patience.
Posted
Apr
17
,
2025
-
17:18
BST
Identified
The issue has been identified and a fix is being implemented.
Posted
Apr
17
,
2025
-
14:53
BST
Update
Thank you for your ongoing patience. Our engineers are currently on site and working towards restoration.
Posted
Apr
17
,
2025
-
12:50
BST
Investigating
We apologise for your service disruption. Our Network Operation Team is investigating for a resolution and thank you for your patience.
Posted
Apr
17
,
2025
-
10:57
BST
This incident affected: Internet Network (Cambridgeshire & Huntingdonshire).
×
Subscribe to Incident
Subscribe to updates for
Suffolk - Sudbury (ngmf-01)
via . You'll receive .