Network issue - Sudbury
Incident Report for
Gigaclear
Resolved
This incident has been resolved.
Posted
Nov
27
,
2023
-
11:36
GMT
Identified
The issue has been identified and engineers are working on a fix.
Posted
Nov
26
,
2023
-
13:35
GMT
Investigating
We have detected an issue affecting multiple cabinets and customers connected to them in Sudbury. Our engineers are investigating the cause.
We will update this page with further information as soon as we have identified the fault. We do not currently have an estimated time of recovery.
Posted
Nov
25
,
2023
-
21:57
GMT
This incident affected: Internet Network (Essex).
×
Subscribe to Incident
Subscribe to updates for
Network issue - Sudbury
via . You'll receive .