Network Issue - Essex & Cambridgeshire

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 14:20 GMT

Investigating

We are currently aware of an issue affecting network services in the areas listed below. Our engineering teams are working urgently to restore full service as quickly as possible.

Essex: Duddenhoe End, Wendens Ambo, Little Walden, Newport, Ashdon.

Cambridgeshire: Great Abington, Great Chesterford, Little Chesterford, Linton, Whittlesford.

We apologise for any inconvenience caused and appreciate your patience.
Posted Feb 24, 2026 - 12:37 GMT
This incident affected: Internet Network (Essex).