Service Issues in Newtown
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Feb 23, 2021 - 08:55 GMT
Update
Our engineers are on site and have located the break, further works will be required to restore service.
Posted Feb 19, 2021 - 15:36 GMT
Update
Our Engineers are on their way to begin investigation and are due to arrive at approximately 1400 today.
Posted Feb 19, 2021 - 11:59 GMT
Investigating
We are currently investigating customer reports of service issues in the Newtown community, further updates to follow as we have them.

Thank you for you patience.
Posted Feb 19, 2021 - 11:59 GMT
This incident affected: Internet Network (Gloucestershire).