Unplanned Incident - Woodnewton
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Aug 05, 2022 - 11:11 BST
Investigating
We are investigating an issue affecting customers attached to the cabinet in Woodnewton.

Updates will be posted here as soon as the fault has been identified. We do not currently have an estimated time of recovery.
Posted Aug 05, 2022 - 10:06 BST
This incident affected: Internet Network (Northamptonshire).