Unplanned outage in Acton Green
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Feb 19, 2021 - 07:37 GMT
Identified
Unfortunately, it’s taking a little longer than we thought to resolve the issue that’s affected your broadband service today. Our engineers are still hard at work trying to resolve the issue and are hoping to restore the service in your area as soon as they can.
Posted Feb 19, 2021 - 06:30 GMT
This incident affected: Internet Network (Herefordshire).