Stanstead Mountfitchet, Essex
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 13:14 BST
Investigating
We have identified an offline cabinet in the Stanstead Mountfitchet village currently affecting a small number of customers in this area. Our Direct Labour Team have been engaged and will be investigating the root cause of this issue. We are aiming to restore services as quickly as we can.

Please accept our apologies for any inconvenience.
Posted Apr 26, 2024 - 09:09 BST
This incident affected: Internet Network (Essex).