Network issue - Piddington, Calvert, Worminghall, Marsh Gibbon, Twyford, Botolph Claydon
Incident Report for Gigaclear
Resolved
Gigaclear networks have informed us that the fibre has been repaired and all service are live once more. Should you still have an issue with your service, please do try rebooting your router and trying your connection again. Should you still be disconnected, please, do contact our care team on 01865 591 131, or email support@gigaclear.com.
Posted 9 days ago. Oct 11, 2019 - 07:08 BST
Identified
Gigaclear Networks are still working on the issue with the service in your area. We have engaged additional resource in order for us to get your broadband back up and running.
The team will continue to work on the broken fibres until all services have been restored.
Unfortunately at this stage, we do not yet have an estimated time of recovery, however we hope to update you in the next couple of hours with restoration time.
We would like to thank you for your patience and again, apologise for any inconvenience caused.
Posted 9 days ago. Oct 10, 2019 - 18:48 BST
Investigating
We have detected an issue affecting multiple cabinets and customers connected to them in Piddington, Calvert, Worminghall, Marsh Gibbon, Twyford, Botolph Claydon. Our engineers are investigating the cause.

We will update this page with further information as soon as we have identified the fault. We do not currently have an estimated time of recovery.
Posted 9 days ago. Oct 10, 2019 - 13:33 BST