Our Direct Labour Team are currently on route to site, and will be investigating the issue in-hand. Thank you for your understanding.
Posted Nov 22, 2023 - 10:47 GMT
Investigating
Our Networking team have been notified of an incident currently affecting services in the Tackley area. Our Direct Labour Team has been engaged to assist, and we are working as efficiently as possible to restore services as soon as we can.
Thank you for your patience.
Posted Nov 22, 2023 - 10:12 GMT
This incident affected: Internet Network (Oxfordshire).