Oxfordshire - Fyfield - (BUC01/FYF01)
Incident Report for
Gigaclear
Resolved
This incident has been resolved.
Posted
Mar
27
,
2025
-
16:35
GMT
Update
Our engineers are on-site continuing to splice the fibre in order to restore your connection. Thank you for your patience.
Posted
Mar
27
,
2025
-
11:05
GMT
Update
Thank you for your patience. Our engineers are on site this morning to start splicing the fibre for restoration.
Posted
Mar
27
,
2025
-
09:00
GMT
Investigating
We apologise for the service disruption. Our team is investigating the issue and working towards a resolution. Thank you for your patience.
Posted
Mar
26
,
2025
-
15:32
GMT
This incident affected: Internet Network (Oxfordshire).
×
Subscribe to Incident
Subscribe to updates for
Oxfordshire - Fyfield - (BUC01/FYF01)
via . You'll receive .