Cuddesdon, Oxford

Incident Report for Gigaclear

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 10:08 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 01, 2025 - 18:41 BST

Update

We apologise for the service disruptions. Our engineers are conducting a full investigation to resolve the issue, and we thank you for your patience.
Posted Apr 01, 2025 - 16:44 BST

Investigating

Gigaclear Networks have informed us that there is an issue with the service in your area. Our engineers are investigating what has caused the problem and are doing everything they can to restore your service as quickly as possible.
Posted Apr 01, 2025 - 13:36 BST
This incident affected: Internet Network (Oxfordshire).