Partial Network outage- Preston Bisset
Incident Report for Gigaclear
Resolved
This incident has been resolved.
Posted 21 days ago. Sep 29, 2019 - 06:12 BST
Investigating
Gigaclear Networks have informed us that there is an issue with the service in your area. Their engineers are investigating what has caused the problem and are doing everything they can to restore your service as quickly as possible.

As soon as we have more information, we’ll let you know when to expect the service back up and running.
Posted 21 days ago. Sep 28, 2019 - 12:12 BST